All Collections
Slingshot Flex
Connect Legacy Slingshot Wallet to Flex
Connect Legacy Slingshot Wallet to Flex

OG Slingshot users, welcome!

R avatar
Written by R
Updated over a week ago

OG Slingshot users, welcome! If you have previously swapped on Slingshot (either web or mobile wallet app), you are invited to the closed beta of Slingshot Flex!

To gain access, connect a wallet you have used to swap on Slingshot Legacy and sign a message allowing us to verify your activity. Rest assured, this will not trigger a blockchain transaction or incur any gas fees for you.

Web App

  1. Click "New User"

  2. Instead of entering an Invite Code, click “Used Slingshot (legacy) before?”

  3. Choose the your wallet in the wallet selection menu and connect to it

  4. Sign the message in your wallet

  5. If your wallet is eligible, an Invite Code will populate

  6. Now create your non-custodial Flex account!

Mobile PWA

  1. Tap "Sign Up."

  2. Instead of entering an Invite Code, click "Used Slingshot (legacy) before?"

  3. On the next screen, select the wallet you want to connect to Flex. The images below show Slingshot Wallet

  4. Follow the prompts to connect your wallet and sign the message

  5. If your wallet is eligible, an Invite Code will populate

  6. Now create your non-custodial Flex account!

FAQ

I’ve used Slingshot Wallet, why don’t I have access to Flex Closed Beta?

Only users who have swapped on Slingshot legacy are invited to Flex Closed Beta.

What wallet should I connect if I have swapped on Slingshot using multiple wallets?

Use any wallet to gain access to Flex! You can link other wallets after creating an account. Your activity on legacy Slingshot will give you a headstart on your Flex experience!

Can I link more than one eligible wallet to my Flex account?

Yes! And this will give you more XP.

XP?

Our goal is to reward loyal users of Slingshot. For starters, your recent XP determines your Flex fee tier.

I can’t connect my Slingshot Wallet to the Web App via WalletConnect

We recommend mobile users connect to Flex using PWA.

What does the “Unsupported session, only EVM compatible networks are supported” message mean when trying to connect?

Ignore that error message and proceed with connecting.

How do I connect more wallets?

Go to your profile menu, then select “Link Legacy Wallet.”

Did this answer your question?